Back to overview
Resolved
Remaking major payment systems
Jul 14, 2026 at 2:30am UTC
–
Jul 14, 2026 at 2:30pm UTC
Affected services
CheapSnacks
Resolved
Jul 14, 2026 at 2:30pm UTC
Maintenance ended
Affected services
Updated
Jul 14, 2026 at 3:21am UTC
We need to fix bugs
Affected services
Updated
Jul 14, 2026 at 3:19am UTC
Checking if everything works
Affected services
Updated
Jul 14, 2026 at 3:16am UTC
Extended maintenance
Affected services
Created
Jul 14, 2026 at 2:30am UTC
We will be changing the payments system to make it fairer towards drivers
Affected services